blog.sarlok.com - Coffee!

System time:  Mon/12/17 : 09:09:39

Some Kind of Blue

So, I'd like to rant about the sim I dabbled with for VRRP tonight.
But... as I was on call this weekend and things have gone from bad to bleak, and I'm getting up to drive to - then up a mountain in 5 and a bit hours, I might save it for another time.

Here's some moar Deadmau5

Also, I'm not sure how we got onto the subject, but I was discussing this intro over sushi the other night. I gotta get me one of those helmets.

Rondoparisiano

Today I was subtly reminded why piling 3 class C's onto a single 802.1q sub-interface is a bad idea.
1327 broadcast packets per second, spat out again on 8 other ports wasn't a good thing. 12,000 packets per seconds of garbage tends to be a significant wrench in the works on a router that peaks at 20,000 under ideal circumstances. I'm sure there's some quirks I'm not accounting for with the performance lost over the module rather than the router itself, but meh.
Fortunately, it was from a single host with, what seems to be (after a closer inspection of the packet capture), a seriously damaged D-Link router. I know, I know! You can hardly believe it... a messed-up D-Link router!

As a result of this occurrence, I realized I should probably test MAC filtering on a router with IOS, as it's come up once or twice before for other various amusing reasons.

Unfortunately, the only feasible way I've found that works seems like a bit of a stupid hack.
Seeing as MAC filtering ACL's can only be applied to an L2 interface, ports configured for VLAN access or routing are a no-go. Though I was surprised that a dot1q trunk wouldn't work either... I may have to look into that one further some other time.

Soooo...

Works:

bridge 1 protocol ieee

access-list 700 deny 1122.3344.5566
access-list 700 permit 0000.0000.0000 ffff.ffff.ffff

int bvi 1
ip address 10.1.1.2
exit

int fa0/0
bridge-group 1
bridge-group 1 input-address-list 700
exit

Does not work:

bridge 1 protocol ieee

access-list 700 deny 1122.3344.5566
access-list 700 permit 0000.0000.0000 ffff.ffff.ffff

int fa0/0
no ip address
switchport mode trunk
switchport trunk allowed vlan 123
exit

int vlan 123
ip address 10.1.1.2
bridge-group 1
bridge-group 1 input-address-list 700
exit

!!-----or----

int fa0/0
no ip address
bridge-group 1
bridge-group 1 input-address-list 700
switchport mode trunk
switchport trunk allowed vlan 123
exit

int vlan 123
ip address 10.1.1.2

Now, if I could just get that to work with vlan sub-interfaces, it might be more useful. Oh-well... maybe if I'm feeling bored one day I'll give it another shot.
There might be a typo or two in there, but I've already shut down the sim and can't be bothered to start it up again to pull out the configs I wound up with.

Huh. 00:18am. On the plus side, It's friday I guess...

I Remember

Work get's an honourable mention today, but for not any particularly good reason.

This is a pretty neat song. Deadmau5' album "Random album title" is yet another of the few I've ever come across that I fully enjoy all of the tracks therein.



These guys are also quite different.
Yet another case where I can't get this song on iTunes... oh-well. Wiretap to the rescue yet again!

<edit>
Youtube video was pulled. Too lazy to find it again. Was by Something ala Mode though.
</edit>

It's odd how one's tastes can change.

Quello è tutto.

Sometimes things get, whatever

I needed a good laugh.

That is all.

Quicksilver FTW

It suddenly dawned on me about 10 minutes ago, just how incredibly reliant on Quicksilver I am these days.
As far as productivity based apps go, I can't really remember how I managed without it. It's a shame all the windows spinoff's are so kludgy and stupid... Using it on my laptop at work would be nothing short of fantastic.

Heh, I was showing a friend of mine after telling him it's "The best app evar!!!1!one!". That very instant, I managed to find this amusing bug. Never before has "Disappeared in a puff of logic" been more fitting a term.
I'm happy to report, it was fixed last release. :]

On the note of cool apps, I actually sat down and used the Espresso web editor for a while tonight. I got it sometime last year as part of the Macheist bundle 3.
Where useful, tasteful, and easy to run with apps are concerned, this is right up there.

Humm... 1:30am again. Go figure.

<edit>I reckon It would be kinda neat to be able dance like this guy, on demand. And I'm not just saying that because almost all the songs on his uploads are in my playlist somewhere...
Heh, the carpet's pretty sweet too.</edit>

Open Your Eyes

I was telling a friend of mine about this comic over at Three Panel Soul.
To the uninitiated, it's a jab at Massively Multiplayer online games, where you pay a month-to-month fee to play and do the same things over and over. If you're lucky, you get enough points from doing the same thing over and over, and are rewarded with a level. This lets you do the same things over and over again in new and exciting ways at no extra charge!

In other news, I learned that running 'debug arp' on a router passing a little shy of 11,000 packets/sec is not a good plan.
Given as soon as I punched in that command, it starts spitting the data out of a console port at 9600baud, which I can guess would have been 960 characters per second in a perfect world (which I'm sure it wasn't).
At about 80-100ish characters per arp, It really didn't end well.
I'm sure 960CPS is way out (9600bits/sec, 10bits/char), but It's close enough I can be bothered to guestimate without getting carried away.

Swas Boona

For those that do such things, enabled the RSS feed-majig.
feed://blog.sarlok.com/?q=rss.xml.
It even gives me a little RSS picture (the thing) below the random image ticker. Wee.

Also, stupid work. It's ruining my ability to MUD...
...among other things.

> i
832/832 HP 445/445 Mana 1000 Align 10395904 tnl >
You are carrying:
     a canvas bag

832/832 HP 442/445 Mana 1000 Align 10395904 tnl >
> ls -la
Huh?

832/832 HP 442/445 Mana 1000 Align 10395904 tnl >
> pwd
Huh?

832/832 HP 442/445 Mana 1000 Align 10395904 tnl >
> slap self
You slap yourself.  You deserve it.

832/832 HP 442/445 Mana 1000 Align 10395904 tnl >
> who

-----------------------[ D E A D L Y  C H A R A C T E R S ]-----------------
44 Pala HElf OOC   Cylix Wasawarriorwayayix. [Helper]
1 player, 12 high this reboot. System time: Fri Aug 13 03:49:25 2010

832/832 HP 442/445 Mana 1000 Align 10395904 tnl >
> title keeps typing 'ls -la' instead of look..
Ok.

> who
832/832 HP 442/445 Mana 1000 Align 10395904 tnl >

-----------------------[ D E A D L Y  C H A R A C T E R S ]-----------------
44 Pala HElf OOC   Cylix keeps typing 'ls -la' instead of look... [Helper]
1 player, 12 high this reboot. System time: Fri Aug 13 03:49:36 2010

Another sacrifice to the gods of losing you...

Looking for some problems in one of our vast network segments, and came across this little gem that made me chuckle.

----e@host:~ $ sudo tcpdump -envvi em2 arp
*loads of usual junk*
01:56:41.277605 00:c0:69:0b:41:34 ff:ff:ff:ff:ff:ff 0806 60: arp who-has 192.168.1.0 (e3:06:3e:74:40:06) tell 192.168.1.121
01:56:41.277670 00:c0:69:0b:53:e4 ff:ff:ff:ff:ff:ff 0806 60: arp who-has 192.168.1.0 (48:7f:01:bb:67:e2) tell 192.168.1.120
*yet more junk*
02:12:46.370885 00:c0:69:0b:41:34 ff:ff:ff:ff:ff:ff 0806 60: arp who-has 192.168.1.0 (6a:11:12:f2:50:d5) tell 192.168.1.121
02:12:46.370942 00:c0:69:0b:53:e4 ff:ff:ff:ff:ff:ff 0806 60: arp who-has 192.168.1.0 (7f:06:63:17:d1:34) tell 192.168.1.120
*loads more junk*

Surprise! Who has my net? Nevermind the fact that the MAC addresses it seems to believe it's net exists on are non-existent and seem to change a little while later.
That's almost as amusing as the device I saw that was arping for itself a while back. I should try and find that again, don't think it was ever fixed.

Weee...

Coco

Nothing significant to say today.
I may have mentioned a thing or two about Dwarf Fortress, but here's another exciting story depicting the epic goodness that can unfold from within a budding city.

Also, this quote from a PC Gamer interview with Tarn Adams, one of the two developers, left me quite bedazzled as to why these 'bugs' weren't left in as features.


PC Gamers: Do you have any favourite hilarious bugs or test results from over the years?

Tarn Adams: My favorites are the one where the farmer walked over to the furniture stockpile, grabbed a bed, walked over to his farm and planted it, and the one with the injured hammerer. The hammerer is the dwarven executioner. When both of his arms were broken and he was unable to hold his hammer to administer Dwarven Justice, he still went ahead with the punishment, but he bit his victims. This included shaking his head vigorously and tearing their arms off, which he then held in his mouth for years.

Check your basic groove

blog.sarlok.com comin' atcha loud and clear from fluctuator.
Setup httpd properly as opposed to the un-chrooted mess of a setup that was running as _lighttpd:_lighttpd before.

New webmail is in action, though - still with one or two bugs left to work out, but nothing major.

New mail server is live and processing messages. It has to be said, I learned a metric crap-ton playing around with vpopmail and trying to make it play nice with all the patching that was done.
It's comforting to know I'll probably never have to do anything to my mail-server ever again short of come up with a better way to allocate storage to the queues and imap mailboxes.

Best of all, everything is so much faster than it was before.
Good thing too, kinda makes it worthwhile.

I'll give things a week or so before I shut down and de-rack thallid.

In other news... hmm. Short of an unfortunate series of tragedies regarding co-workers, and above all else - friends, there isn't much. Besides, I can't really comment on the former here of all places.

Shine Shine

<edit>
Added eight images to the gallery. Random findings in the West Fraser timber park on one of it's many secret trails.
This should help counter the large amount of random code and console snippets that have found their way on here.
</edit>

OpenBSD's em driver performance under vmware is still a bit lacking it would seem. Maybe I just got my hopes up since some of the changelog's notes since 4.3

root@scrollrack:/tmp/memnarch_tmp # dd if=/dev/zero of=/tmp/memnarch_tmp/testfile bs=16k count=16384
16384+0 records in
16384+0 records out
268435456 bytes transferred in 26.807 secs (10013587 bytes/sec)
root@scrollrack:/tmp/memnarch_tmp # dd if=/dev/zero of=/tmp/memnarch_tmp/testfile bs=16k count=16384
root@scrollrack:/tmp/memnarch_tmp # dd if=/tmp/memnarch_tmp/testfile of=/dev/null bs=16k            
16384+0 records in
16384+0 records out
268435456 bytes transferred in 27.122 secs (9897256 bytes/sec)
root@scrollrack:/tmp #
(trimmed)
root@cursedscroll:/home # dd if=/dev/zero of=/home/testfile bs=16k count=16384
16384+0 records in
16384+0 records out
268435456 bytes transferred in 88.335 secs (3038810 bytes/sec)
root@cursedscroll:~ # dd if=/home/testfile of=/dev/null bs=16k&
[1] 29127
root@cursedscroll:~ # kill -s INFO 29127
4009+0 records in
4009+0 records out
65683456 bytes transferred in 54.125 secs (1213550 bytes/sec)

Though this is a little over three times as fast with fluctuator than it was on thallid, it's still far, far less than I was hoping for.
It would also seem the memory leak on thallid is crushing read performance of it's nfs shares... funny, I would have expected read & write to be messed up equally. Oh-well.

Maybe the new vmt (4) driver will provide some joy.
I should probably sort this out before getting too much further with having sql, httpd, et al; on a separate virtualmachine... allthough, I suppose 80mbit/sec really isn't all that bad compared to 28, but It would be nice if I could get closer to the 400-550mbit/s I'm getting from the virtual disks at least.

<edit>Then again, maybe vmt will do nothing helpful.
vmt provides access to the host machines clock as a timedelta sensor.
</edit>

One More Time

Well, spamassassin's in.

root@scrollrack:~/cat sample.txt | mail -s Testing! test@sarlok.com

From - Sun Jul 18 01:24:09 2010
X-Account-Key: account4
X-UIDL: 1279441442.10124.scrollrack.sarlok.com,S=1107
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                
Return-Path: <root@scrollrack.sarlok.com>
Delivered-To: test@sarlok.com
<strong>X-Spam-Flag: YES
X-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on
scrollrack.sarlok.com
X-Spam-Level: **************************************************
X-Spam-Status: Yes, score=1000.3 required=5.0 tests=AWL,GTUBE,NO_RELAYS
autolearn=no version=3.2.5
X-Spam-Report:
* -0.0 NO_RELAYS Informational: message was not relayed via SMTP
* 1000 GTUBE BODY: Generic Test for Unsolicited Bulk Email
*  0.3 AWL AWL: From: address is in the auto white-list</strong>
Received: (qmail 26581 invoked by uid 0); 18 Jul 2010 08:24:02 -0000
Date: 18 Jul 2010 08:24:02 -0000
Message-ID: <20100718082402.15611.qmail@scrollrack.sarlok.com>
From: root@scrollrack.sarlok.com
To: test@sarlok.com
<strong>Subject: *****SPAM***** Testing!
X-Spam-Prev-Subject: Testing!</strong>

Subject: Test spam mail (GTUBE)
Message-ID: <GTUBE1.1010101@example.net>
Date: Wed, 23 Jul 2003 23:30:00 +0200
From: Sender <sender@example.net>
To: Recipient <recipient@example.net>
Precedence: junk
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

(clipped)

Ugh. I've suddenly remembered why I've left clam until last... It needs maildrop :(
Maybe I'll just not bother right now.
At this point, I should be able to have copies of messages from the old mail virtualmachine forwarded to the new one for a semi-realistic test for a few days.

That really only leaves needing to build up the new memnarch virtualmachine, and move webmail, this blog, the sql database, et al; to it.
Then thallid can be retired!

So close, and yet so far.. ...1:30am? Huh. Bed time I suppose.